This project is read-only.
1
Vote

The Website cannot be found.

description

After successfully deployed when i click the button change password content display error message "The webpage cannot be found"

I will be so appreciate if someone can help me.

Thank you in advanced.

file attachments

comments

Litan wrote Oct 2, 2015 at 3:19 PM

Solution Properties

wrote Oct 2, 2015 at 3:20 PM

wrote Oct 2, 2015 at 3:20 PM

jasjitchopra wrote Oct 2, 2015 at 4:00 PM

Can you retract and re-deploy the solution? Does not look like it deployed properly in your farm. Also - please test this in another farm. Seems like issue in your farm setup other than anything else.

danielretief wrote May 18, 2016 at 2:41 AM

What you can do is extract the .wsp file using 7zip, then navigate into the folder 'ChangePassword_ChangePassword'>'ChangePasswordLink' and then edit 'Elements.xml'. Change the line
     <UrlAction Url="javascript:(function () { var o = { url:'/_layouts/15/ChangePassword/changepassword.aspx', title: 'Change Password',width: 350, autoSize: true, showClose: false, }; SP.SOD.execute('sp.ui.dialog.js', 'SP.UI.ModalDialog.showModalDialog', o); }) ();"/>
Change the url /_layouts/15/ChangePassword/changepassword.aspx' to match where it actually is, so that might be /_layouts/ChangePassword/changepassword.aspx or you might need to put the full url http://yourdomainname/sites/yoursite/layouts/ChangePassword/changepassword.aspx

e.g.
     <UrlAction Url="javascript:(function () { var o = { url:'http://yourdomainname/sites/yoursite/layouts/ChangePassword/changepassword.aspx', title: 'Change Password',width: 350, autoSize: true, showClose: false, }; SP.SOD.execute('sp.ui.dialog.js', 'SP.UI.ModalDialog.showModalDialog', o); }) ();"/>
Then use the software 'CabPack' to make a cab file from the 'ChangePassword' directory that you extracted before. Rename the cab file back to a wsp file then update the package using the following powershell (as admin) command:
Update-SPSolution –Identity ChangePassword.wsp –LiteralPath “C:\Path\To\Your\ChangePassword.wsp” –GacDeployment
Refresh your sharepoint page and try using it again.